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GETTING STARTED
Introducing RemoteX
RemoteX is a powerful new application that allows you to share your desktop with another user while
on a Skype call. A “lite” version of our standard-setting RemoteCall 4.0 remote support software,
RemoteX downloads and installs in minutes on any Windows PC (or Intel Macs with virtual Windows
machines) running Skype and provides instant access to desktop sharing. In Skype, simply click on the
Tools > Do More menu (or right-click a contact and select Do More from the drop down menu) and
select the RemoteX icon to share your desktop or view and even take control of your contact’s desktop.
×
×
×
×
×
×
×

Work on a single document together as if you were at the same desk.
Collaborate on a web page.
Teach a friend how to use new software by showing them in real time, on their PC.
Surf the Internet together.
View photo albums and slideshows together.
Show PowerPoint or other presentations.
Fix pesky computer problems.

Simple desktop sharing added to the already free and easy Skype.

Terminology Used
Local PC

The computer you are using to connect with a friend or family member

Remote PC

Your contact’s PC you are remotely connecting with via Skype

Session

The connection between the local and remote PCs

P2P

A direct connection (peer-to-peer) between two PCs

Gateway

A connection between two PCs relayed through a web server

VRVD

Virtual Remote Video Driver (VRVD) is RemoteX’s proprietary video driver

GDI

Graphics Device Interface is a Windows video driver

Session Status Window

The window displayed on the remote PC desktop indicating an active session

Extras Manager

A direct link to Skype’s plug-in database allowing you to download the latest plug-ins

API Access Control

Manage Skype’s plug-in permission settings via the API (application programming
interface) Access Control Console
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RemoteX Quick Connect
This little section explains just how easy it is to get up and running with RemoteX for the first time.
Since you are already connected to your Contacts via Skype, you can connect your computer to theirs in
three easy steps.
1. Download and install the RemoteX plug-in from the Skype Extras Gallery.
2. A splash screen will ask if you want to Invite someone to use this Extra. Choose the person you
would like to connect with from the list of available contacts and then click Continue.
3. RemoteX will automatically send a Skype Extras link to your contact so they can install the plugin. As soon as they have installed it, you will automatically be connected!
NOTE: When running RemoteX for the first time you will be prompted to select the Skype
permission setting. You must select the “Allow this program to use Skype” option or RemoteX
will not function.
From that point on, connecting is as simple as selecting Do More > RemoteX from your Skype menu and
then selecting the person you would like to connect with. The other way to do it is to right-click on the
contact you want to connect with, then select Do More > RemoteX. The RemoteX plug-in will do the rest.

System Requirements
Local and Remote PC
OS
Hardware
Web Browser
Disk Space
Internet Connection

Windows 2000/2003, XP, Vista
Pentium III 1-GHz or higher
MS Internet Explorer 5.0 or higher
8 MB
56 kbps modem or higher

Technology and Security
RemoteX does not contain any adware, spyware or other malware. Connecting through one of our relay
servers, a direct link is established between the two PCs and is maintained until the user ends the
session. We also guarantee the fastest remote connection possible due to RemoteX’s Virtual Remote
Video Driver (VRVD) and high speed packet switching technology.

Cordeos Corp. | RSUPPORT CO. Ltd., ©2008

www.remotecall.com

RemoteX User Guide

Page |3

Downloading RemoteX
To download RemoteX to your local PC, you can use the Skype Extras Manager or download the .sparc
file directly from our website (www.remotecall.com/remotex.asp). To see a video of the installation
process, follow this link: http://www.remotecall.com/remotex/demo.asp.
Using the Skype Extras Manager
1. Log in to Skype and click Tools > Do More > Get Extras

2. Click Sharing from the plug-in categories on the left
Note: If you do not see RemoteX listed in the Extras Manager > Sharing
category, you must update the Extras Manager.
To do so:
1.
2.

Click Options in the bottom left corner of the Extras Manager
Click Update Now from the update tab and wait a few moments

Once the Extras Manager has updated itself the plug-in should be visible
from the Sharing category and ready for download.
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3. Find RemoteX in the list of applications on the right and click the green play button to open the
download the plug-in.

4. An Install new Extra splash screen will appear. Click the checkbox next to I agree and accept the
terms of the publisher’s End User License Agreement, then click OK.

5. A dialogue box will appear asking you to “Invite someone to use this Extra”. If you want to
connect to one of your contacts, select their name from the list and click Continue.

Note: If you don’t want to connect with a
contact right away then just click Cancel.
You can launch a session afterwards by clicking a
contact from your Skype contacts list.
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6. RemoteX should now be installed and ready to work with Skype.

Downloading from RemoteCall.com
Go to www.remotecall.com/remotex.asp and click Get RemoteX Now! from the side bar on the right.
After downloading, double click the RemoteX icon to start the set up process. Refer to steps 4-6 from
the previous section.
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Connecting with a Skype User
1. Right-click a Skype contact and select Do More > RemoteX

2. The remote user will be prompted to accept the invitation to use RemoteX

Note: If the remote user does not have the Skype plug-in installed, they will automatically be
prompted to download it. This may take a minute or two depending on their internet
connection.
3. Once your invitation has been accepted you will have the choice of:
a. Displaying your screen to the remote user
b. Viewing the remote user’s screen
Make your selection and click Go
IMPORTANT!
When running RemoteX for the first time you will be
prompted to set the permission for the plug-in.
You must select “Allow this program to use Skype”
or RemoteX will not function.
This must be done by both you and the remote user!
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USING REMOTEX
Local User Interface
Remote PC Name and IP Address

Main Menu and Toolbar

Session Status Window

Status Bar

Main Menu and Toolbar
The features of RemoteX are easily accessed using a standard menu system, and/or a button icon
toolbar. The RemoteX interface includes the following menus and toolbar:

Keyboard/Mouse Control takes control of the remote PC’s keyboard and mouse.
Mouse Chase displays the real-time location of the remote PC’s mouse cursor.
Laser Pointer highlights sections of the remote desktop, using a dot or arrow.
Draw allows you to draw on the remote desktop in real time.
Zoom adjusts the scale of the RemoteX Console in sizes of 50%, 60%, 70%, 80%, 90% and 100%.
Performance Optimization let’s you improve session performance by optimizing connection and
display settings in RemoteX during the session.
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The RemoteX interface includes the following menus:
 Connection – Session management and connection information
 View – Screen size options and toolbar/interface settings
 Tools – Tools and Performance Optimization
 Help – Information about RemoteX
Connection
Disconnect
Connection
Information
Exit
View

Use the Connection menu to disconnect an existing session or check connection
details.
Disconnects the active session.
Displays relevant information about the current session, such as, connection status,
connection method (Gateway or P2P), total session time, and remote PC name, IP, and
OS version.
Exits and closes RemoteX.

Status Bar

Use the View menu to configure the RemoteX Console screen size and user interface
features.
Maximizes the RemoteX session window to full screen. A quick menu is available at the
top of the screen while in full screen mode. To return to a resizable viewer window, click
the Full Screen icon.
*Note: You can only enter full screen mode if the remote desktop’s resolution is the same
or higher than the local PC’s.
Scales the image of the remote desktop to fit within the session window.
Displays/hides the following Basic Toolbar at the top of the RemoteX Console:
 Basic Toolbar
Displays/hides the status bar at the bottom of the session window.

Tools
Always on top
Tools

Use the Tools menu to select a specific RemoteX tool or function.
Places the RemoteX Console on top of other windows.
Access RemoteX support tools and functions:

Full-Screen

Window-Scale to Fit
Toolbar

Session Status Window
Once connected, a remote user applet, the Session Status
Window, should appear on the remote desktop.
This applet allows for quick control of the remote session.
Either user can click Disconnect to immediately end the
connection. A remote user can also immediately suspend user
control of the mouse and keyboard by pressing Ctrl + Alt + Shift.
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Display Options
Zoom and Scale-To-Fit
During a session you may want to adjust the size of the viewer to fit the entire image of the remote
desktop. You can do this in two ways.
First, you may try adjusting the zoom percentage of the image. By default the image is zoomed at 100%,
however the remote desktop may have a larger screen resolution than the local PC you are using.
By clicking the Zoom icon
window.

you can adjust the scale of the displayed image until it fits within your

The second way is to click Window-Scale-to-fit from the “View” menu. This will automatically scale the
current image to fit within the viewer.

Full-Screen Mode
During a session you can view the remote desktop in full-screen mode (View > Full-Screen Mode).
You can use the Basic Toolbar located at the top of the screen to access tools and features while in fullscreen mode. You can exit full-screen mode at any time by clicking the Exit Full-Screen icon
1
2
3
4
5
6

1.
2.
3.
4.
5.
6.

.

Exit Full-Screen
Mouse/Keyboard Control
Mouse Chase
Laser Pointer
Draw
Performance Optimization

Display Color Depth
You may customize the color depth in the RemoteX Console to enhance
image quality or improve performance. Open Performance
Optimization
and select the General tab, then adjust the color
depth of the Local Display.
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Screen Scrolling
While viewing the remote desktop at 100% scale you may not be able to see the entire screen at once.
Using the screen scrolling feature you can navigate within the viewer, without the need to zoom out and
lose detail. RemoteX has two screen scrolling functions:
Auto Scroll: Moving your cursor to the edge of the RemoteX Console window will automatically scroll in
the direction of your cursor.
Panning Scroll: Clicking and holding the middle mouse button let’s you drag the screen in the direction
you wish.

Ending the Session
The remote session can be ended in one of three ways.
1. Click Connection > Disconnect from the menu
2. Close the RemoteX Console by clicking the red (X) in the top right corner
3. Click the Disconnect button on the “Session Status” window located on the remote desktop
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Performance Optimization/Viewer Settings
When a session is launched, RemoteX will start with default settings enabled. You can, however, make
changes to these settings during an active session by clicking the Performance Optimization icon
or
by using the menu Tools > Performance Optimization. Here you can adjust settings to boost
performance or display quality.

General
Remote Display
Change the remote PC’s display resolution and color depth.
Local Display
Change the display color depth in RemoteX.
NOTE: Lowering the displayed color depth will increase performance.

Advanced
Network Type
Select the network connection type (LAN, ISDN/DSL/Cable, or
Modem/Satellite) according to the remote PC’s available bandwidth.
NOTE: Choosing the appropriate connection speed is important as it
will optimize your remote connection speeds.

Transfer Mode
The transfer mode selection is disabled for this product. The default
“Automatic Mode” is enabled.
Screen Scroll
Select the screen scrolling functions in the RemoteX session window.
Auto Scroll will pan the screen automatically when the cursor reaches the edge of the screen.
Panning Scroll is a click and drag method of scrolling. Simply hold down the middle mouse button to
click and drag the screen.
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Examples of Session Settings
For Low Speed Internet
RemoteX can connect to users with low-speed Internet access—even those using a 56K dial-up modem
or a 2-way satellite for Internet access. While in a remote session click the Performance Optimization
button

on the Toolbar to adjust the following settings:
 Network Type: Modem/Satellite
 Color depth: 16 or 256 Colors

For Graphic and Multimedia Files
If you are connecting with a user to watch videos, view pictures or use a graphic intensive application,
we recommend adjusting the following settings for the best display quality and response time:
 Network Type: LAN
 Color depth: True Color
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REMOTEX FAQS
1.

So what is RemoteX anyway?
RemoteX is an Extra designed for Skype that allows you to share your desktop with another user while on a
Skype call. A lighter version of our standard-setting RemoteCall 4.0 software, it provides an instant, secure
remote access solution.

2.

What are the RemoteX system requirements?
RemoteX requires Skype (of course) and Windows 98/2000/XP/Vista. At this point, RemoteX does not work
with Mac OS X or Linux.
If you use an Intel Core Duo Mac with Parallels Desktop or Boot Camp installed, you can use RemoteX with
Skype on the Windows virtual machine.

3.

What is Skype Extras Manager?
The Skype Extras Manager is where Skype links you to all of the plug-ins that are currently available.
Unfortunately, Skype doesn’t automatically update your Extras Manager for you when new plug-ins are
available, so you must do this manually if you want all the latest and greatest plug-ins (including RemoteX). If
RemoteX is not listed in the Extras Manager it will not start.

4.

Can I connect to a remote PC that is behind a firewall or proxy?
Yes, RemoteX works transparently through any firewall or proxy without the need to change your existing
network settings.

5.

Can I use RemoteX by myself to access my home/work computer?
No. RemoteX was designed as a support tool to connect and work “with” another remote user. There are also
security concerns to consider when allowing unattended remote access. We do, however, offer another
standalone application called RemoteView intended for this purpose. For more information on RemoteView,
please visit https://rview.net.

6.

Can I connect with multiple machines simultaneously?
No, RemoteX can only connect two Skype users.

7.

Can I use a dual-monitor display with RemoteX?
Yes, RemoteX supports and displays dual monitor setups. Both displays will be shown together simultaneously
in the RemoteX Viewer window.

8.

Can I transfer files to and from the remote PC?
RemoteX does not support file transfers itself, but you can transfer files via Skype’s Send File function.

9.

Does the remote user know when the computer is being controlled?
Yes, a dialogue box appears on the screen notifying the remote user that a connection has been established.
During the remote session, “Connected” is displayed in the bottom right corner of the screen. The remote
user’s wallpaper is temporarily disabled and replaced with a black background.
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10. Why does the session connect as a gateway and not a P2P when I’m connecting to a LAN PC?
If you are running RemoteX for the first time or have not added RemoteX to the Windows Firewall Exception
List then it will connect through the gateway. When prompted by Windows Firewall, click Allow to add
RemoteX as an exception and try connecting again.
11. Why am I losing control of the mouse and keyboard when viewing a flash animation or flash video?
There is a compatibility issue with Kaspersky Anti-virus. While this program is running there is a buffering
issue which slows the response of the mouse and keyboard control requests while viewing a flash based
animation or video. To remedy this, you must add the program rcviewer.exe to Kaspersky’s Trusted Zone list.

RemoteX Troubleshooting
1.

Make sure your Extras Manager is up to date!
In order for the RemoteCall plug-in (or any shared Skype Extra) to work properly, your Skype Extras Manager
must be up to date. The person you are using RemoteX with must also have the updated version of Extras
Manager as well, or they won’t play well together.
To update your Extras Manager, you need to do the following:
1) Open the Skype Extras Manager by clicking Tools > Do More > Organize you Extras.
2) Look at the blue hyperlinks in the bottom left-hand corner. Click Options.
3) The Skype Extras Manager Options window will open. In the Updates tab, click Update Now.

2.

Make sure your Skype plug-in permission for RemoteX is correctly set!
You need to check the Skype permission settings for RemoteX and make sure to “Allow this program to use
Skype”! When running RemoteX for the first time, a dialogue box will prompt you to allow the program to use
Skype. You must select “Allow this program to use Skype” or RemoteX will not work.
If you accidentally selected “Do not allow this program to use Skype” or are not sure which selection you
made, you can update the permission setting from Skype’s settings menu.
1) Click Tools > Options...
2) The Skype Options window will open. Click the Advanced button in the list on the left.
3) Look in the Advanced Settings main window. Click the blue hyperlink at the bottom that says “Manage
other programs’ access to Skype”.
4) Select RemoteX and click the Remove button
Now, restart Skype and try running RemoteX again making sure to select the appropriate permission setting
when prompted.
This must be done for both Skype programs!
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CONTACT INFORMATION
RSUPPORT: www.rsupport.com
Technical Support: support@rsupport.com | +82 70 7011-0590
Sales: sales@rsupport.com | +82 70-7011-0590
Info: info@rsupport.com | +82 70 7011-3900
Headquarters
2F, Nano Bldg.
149-11 Bangi-dong, Songpa-gu
Seoul, Korea
138-050
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